09.12.2017

FastNetMon Community Developer notes

FastNetMon has pretty huge list of supported platforms but we focused on following platforms:

  • CentOS 6/7
  • Ubuntu 12.04 / 14.04 / 16.04 only LTS releases
  • Debian 7, 8

And your changes should work with they.

Also we are using Boost library as proven source of well-tested code.

Boost versions across different distributions:

So at 3th of December of 2017 you could use features only from Boost 1.41 (I’m so sorry about it but we should keep compatibility with CentOS 6).

We are using gcc as main compiler. I like clang but some old distros have broken and very old clang and it could not be used. CentOS 6 has pretty old version of gcc without C++ 11 support and we could not use it (I’m so sorry about it also, it’s huge pain).